Jump to content


AR15Armory Announcements


Photo

Colt delta elite full mag issue


  • Please log in to reply
8 replies to this topic

#1 OFFLINE   tinman_12

tinman_12

  • Group:New Members
  • Member ID: 29,109
  • Posts: 9
  • Joined: Dec. 28 2013
  • Location:Florida


Posted Dec. 28 2013 - 06:45 PM

I just bought a new, never fired, Delta elite and when I load eight rounds in the magazine the magazine will not lock in place, there's no play in the spring to allow it to lock up. Any ideas?




#2 OFFLINE   Gmountain

Gmountain

  • Group:Senior Staff
  • Member ID: 417
  • Posts: 57,076
  • Joined: Nov. 20 2005
  • Location:Heliosphere


Posted Dec. 28 2013 - 06:48 PM

Try it with 7?




Signature:

Wag more. Bark less.

 

So many guns, so little time.

 


#3 OFFLINE   tinman_12

tinman_12

  • Group:New Members
  • Member ID: 29,109
  • Posts: 9
  • Joined: Dec. 28 2013
  • Location:Florida


Posted Dec. 28 2013 - 06:59 PM

Try it with 7?

Yes it works fine with 7... but its an 8 round clip so it should lock up with 8. When I load 8 there is no more room in the mag to deflect to let it lock in place. Has anyone else ever heard of this. It seems like a mag issue.


Edited by tinman_12, Dec. 28 2013 - 07:07 PM.



#4 OFFLINE   Gmountain

Gmountain

  • Group:Senior Staff
  • Member ID: 417
  • Posts: 57,076
  • Joined: Nov. 20 2005
  • Location:Heliosphere


Posted Dec. 28 2013 - 07:31 PM

Factory mag?




#5 OFFLINE   tinman_12

tinman_12

  • Group:New Members
  • Member ID: 29,109
  • Posts: 9
  • Joined: Dec. 28 2013
  • Location:Florida


Posted Dec. 28 2013 - 07:56 PM

Factory mag?

yes, Colt




#6 OFFLINE   Gmountain

Gmountain

  • Group:Senior Staff
  • Member ID: 417
  • Posts: 57,076
  • Joined: Nov. 20 2005
  • Location:Heliosphere


Posted Dec. 28 2013 - 08:13 PM

Sometimes the springs need a little working in. Load it with eight, leave it over night, then load and unlad it a few ties, and then try it again.




#7 OFFLINE   tinman_12

tinman_12

  • Group:New Members
  • Member ID: 29,109
  • Posts: 9
  • Joined: Dec. 28 2013
  • Location:Florida


Posted Dec. 28 2013 - 08:48 PM

Sometimes the springs need a little working in. Load it with eight, leave it over night, then load and unlad it a few ties, and then try it again.

Thanks for the input. I'll try it.




#8 OFFLINE   tinman_12

tinman_12

  • Group:New Members
  • Member ID: 29,109
  • Posts: 9
  • Joined: Dec. 28 2013
  • Location:Florida


Posted Dec. 29 2013 - 02:16 PM

I fixed it by take 2 1/2 rounds out of each spring, works just fine now. Thank you everybody that responded.




#9 OFFLINE   Rgood30408

Rgood30408

  • Group:New Members
  • Member ID: 32,108
  • Posts: 8
  • Joined: Jul. 02 2017
  • Location:Golden, CO


Posted Jul. 03 2017 - 05:30 AM

I have factory Colt mags same problem I'll try that. Thanks





Forum Statistics

1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


    Google (1)
Information Center