Jump to content
Sign in to follow this  
tinman_12

Colt delta elite full mag issue

Recommended Posts

I just bought a new, never fired, Delta elite and when I load eight rounds in the magazine the magazine will not lock in place, there's no play in the spring to allow it to lock up. Any ideas?

Share this post


Link to post
Share on other sites

Try it with 7?

Yes it works fine with 7... but its an 8 round clip so it should lock up with 8. When I load 8 there is no more room in the mag to deflect to let it lock in place. Has anyone else ever heard of this. It seems like a mag issue.

Edited by tinman_12

Share this post


Link to post
Share on other sites

Sometimes the springs need a little working in. Load it with eight, leave it over night, then load and unlad it a few ties, and then try it again.

Share this post


Link to post
Share on other sites

Sometimes the springs need a little working in. Load it with eight, leave it over night, then load and unlad it a few ties, and then try it again.

Thanks for the input. I'll try it.

Share this post


Link to post
Share on other sites

I fixed it by take 2 1/2 rounds out of each spring, works just fine now. Thank you everybody that responded.

Share this post


Link to post
Share on other sites

I have factory Colt mags same problem I'll try that. Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...